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Installing CosmosScope
This document describes how to install the CosmosScope product.

Note:   

The installation instructions in this document are the most up-to-date 
available at the time of production. However, changes might have occurred. 
For the latest installation information, see the product release notes or 
documentation.

This document provides instructions for both UNIX and Windows platforms. 
The document includes the following sections:
■ Preparing for Installation                                                                                            
■ Installing the Software (UNIX and Windows)                                                               
■ Invoking CosmosScope on Windows
■ Setting Up the User Environment on UNIX
■ Verifying the CosmosScope Installation on UNIX
■ Viewing and Printing CosmosScope Documentation in Portable Document 

Format
■ Using Command Options
■ Troubleshooting CosmosScope Startup on Windows
■ Uninstalling the Software
■ Customer Support

Important:   

Do not install a later version of the CosmosScope tools over an earlier 
version of the tools.

Preparing for Installation

Before beginning the installation process, read the CosmosScope Release 
Notes. The release notes are in Portable Document Format (PDF) and are 
Installing CosmosScope 3
B-2008.09-SP1



Installing CosmosScope
Preparing for Installation
located at the top level of the CD and in the electronic software transfer (EST) 
download directory. They require a PDF file reader to view and print them. 
Check for the following information:
■ Changes in licensing requirements
■ Changes in memory requirements
■ The operating system versions on which the software is supported
■ Changes made from prior releases

If you have not already done so, retrieve your license keys from the SmartKeys 
Web page at 
http://solvnet.synopsys.com/smartkeys

For detailed licensing information, see the Synopsys Licensing QuickStart 
Guide Web page at 
http://www.synopsys.com/keys

UNIX: You must have root or administration privileges when installing licensing 
or tools in a restricted directory location. 

The installation script requires the Bourne shell to be available 
at /bin/sh.

Windows: Administration privileges are required for installing and uninstalling 
the tool. To ensure a successful installation, confirm that previous releases 
have been uninstalled (see Installing Synopsys Tools, available at http://
www.synopsys.com/install/). If licensing will be installed with this installation, 
you must stop any existing license servers (lmgrd or avantd), then uninstall 
licensing. To stop the avantd FLEXlm license server or FLEXlm license server, 
choose Administrative Tools > Services from the Control Panel. 

Supported Platforms and Compilers 

CosmosScope is available on CD or by EST. Obtain the appropriate binary 
executable files for your operating system.

Table 1 Supported Platforms

Platform Operating System

SUN (Sparc OS5) 32-bit Solaris 9

Solaris 10
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Preparing for Installation
The CosmosScope tool works with the Solaris platform in combination with a 
FORTRAN, C, or C++ compiler. You will need one of these compilers if you are 
writing new readers with the CosmosScope external reader application 
programing interface (API).

PC/Linux, IA-32(x86), 32-bit
PC/Linux, AMD Opteron, 64-bit

Red Hat Enterprise 4.0,SuSE Linux 
Enterprise Server 9 &10 (Supported 
only on IA-32 and AMD Opteron)

Red Hat Enterprise 5.0, SuSE Linux 
Enterprise Server 9 &10 (Supported 
only on AMD Opteron)

Note: SuSE Linux Enterprise Server 10 
is binary compatible only.

PC/Windows, IA-32(x86), 32-bit Windows Vista 32-bit

Windows XP 64-bit

Windows XP Professional 32-bit

Table 2 Platforms and Compilers

Platform C C++ Fortran

SUN Solaris 
(Sparc)

C 5.8 Patch 
121015-01 (Sun 
Studio 11)

5.8 Patch 121017-
08 (Sun Studio 11)

8.2 (Sun Studio 11)

PC/Red Hat Linux gcc 4.2.2 g++ 4.2.2 gfortran 4.2.2

PC/Windows 2000 MS Visual Studio

.NET 2003

MS Visual

Studio.NET 2003

Intel Visual Fortran

9.0 with patch 24

Table 1 Supported Platforms

Platform Operating System
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Preparing for Installation
MATLAB Support

If you need to link to a non-default version of MATLAB, copy all files located in 
the install_home/CosmosScope/bin/Matlab_version directory to install_home/
CosmosScope/bin.

Note:   

For the most current MATLAB versions and platform support, see the 
INSTALL_README.wri file in the product download directory.

Disk Space and Memory Requirements

The disk space requirement varies depending on the platform and the features 
selected for installation. Table 4 shows the maximum space required for 
installing all CosmosScope features on a particular platform. Each CD also 
includes this information in the top-level INSTALL_README.wri file. 

Table 3 MATLAB versions supported in CosmosScope.

Platform Sun Windows Linux

CosmosScope / 
MATLAB

7.0 SP3, 2006a,

2006b

Note: On Sun64 
platforms 2007a

7.0 SP3,

2006a,

2006b,

2007a

2007b,

2008a

32-bit

7.0 SP3, 2006a, 
2006b, 2007a, 
2007b, 2008a

64-bit

2006a, 2006b, 
2007a, 2007b, 
2008a

Table 4 Disk Space and Memory Requirements (in Megabytes) 

Platform Software 
(maximum)

Default temporary directory 
location

Temporary disk 
space from CD / 
EST

Solaris 190 MB /var/tmp 84 MB

Linux 270 MB var/tmp 115 MB
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Installing the Software (UNIX and Windows)
If the default temporary directory has insufficient disk space, use the 
-is:tempdir /mytempdir command-line option to use an alternative 
directory for temporary storage. For example, for UNIX platforms, 

% setup -is:tempdir ~/tmp

or

% CosmosScope_version_platform.bin -is:tempdir ~/tmp

Installing the Software (UNIX and Windows) 

You can install CosmosScope version Z-2007.03 by using a GUI or by using 
text commands. By default, the CosmosScope installer invokes the installation 
GUI. To install CosmosScope by using text commands, see Installing Synopsys 
Tools.

Installing the Software by EST

Download the CosmosScope release to a temporary directory. You can obtain 
the latest CosmosScope download instructions from the SolvNet Release 
Library. 

To install the software on UNIX systems,

1. Double-click the downloaded file, or enter the file name at the command 
prompt. For example,

% CosmosScope_version_platform.bin

where version is the release you are installing. Replace platform with the 
appropriate platform keyword (see Table 1 on page 4).

2. Continue with the steps in Installing Synopsys Tools.

Windows 220 MB %TEMP%  
or
C:\My Documents\temp

81 MB

Table 4 Disk Space and Memory Requirements (in Megabytes)  (Continued)

Platform Software 
(maximum)

Default temporary directory 
location

Temporary disk 
space from CD / 
EST
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Installing the Software (UNIX and Windows)
To install the software on Windows systems,

1. Locate and double-click the .exe file. For example, double-click

CosmosScope_version_win.exe
where version is the release you are installing.

2. Continue with the steps in Installing Synopsys Tools. 

Installing the Software From a CD

Mounting the CD might require root access privileges. If you do not have root 
access privileges, see your system administrator for instructions on mounting 
the CD. For detailed instructions, see Installing Synopsys Tools.

To mount the CD on UNIX systems, 

1. Place the CD in the CD drive. 

Most UNIX systems will automatically mount the CD. If the CD does not 
mount, see Installing Synopsys Tools

2. To invoke the installer, enter 

% /cdrom/setup

or

% cd your_cd_path; ./setup

3. Continue with the steps in “Running the Installation Program,” next.

To mount the CD on Windows systems,

1. Place the CD in the CD drive. 

The installation program should start automatically. If it does not, double-
click the setup.exe executable file, located at the root level of the CD. For 
example,

D:\setup.exe #Where D is your CD drive.

2. Continue with the steps in “Running the Installation Program,” next.
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Installing the Software (UNIX and Windows)
Running the Installation Program

Make certain that any open applications are closed before proceeding with the 
installation. 

When the installation program begins, the Welcome screen appears. Answer 
the installation prompts and click Next to continue. If scroll bars appear in the 
panel, scroll to make sure you have reviewed all available information.

Only the path destination screen, which requires more explanation, is shown. 
(Note that selections shown in this screen are for demonstration purposes only 
and might not reflect the current product version.)

1. Read the Welcome Screen.

2. In the Installation Type window, select the type of installation you want to 
perform. 

UNIX: Select a Typical or Custom installation.

Windows: Select a Typical or Custom installation, or select a Network 
installation to establish network access from a client machine to previously 
installed products on a remote machine.

3. If you selected a Typical or Custom installation, enter a directory name that 
does not include spaces in the Destination box. You can also use the 
Browse button to select a directory.

4. (Windows only) If you have chosen to perform a network installation, create 
a network mapped drive to a remote machine on which the CosmosScope 
software was previously installed. If not, skip to step 6.

5. (Windows only) Set up network access to a remote machine.

The Network installation option allows you to link to applications previously 
installed on other Windows machines. It is assumed that a stand-alone 
CosmosScope installation has already been performed on another 
machine. 

• Enter the source path by using the previously created mapped drive, 
which resolves to the location where the ai_bin directory is located. For 
example, 

S:\Synopsys\Z-2007.03

where S: is your network mapped drive.
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Installing CosmosScope
Installing the Software (UNIX and Windows)
• Enter a destination path name to a location on the local host machine 
where a minimal set of files will be installed. In the Browse window, 
navigate to the directory you want, for example, Z-2007.03. Select this 
directory and click the Open button. The path to the Z-2007.03 directory 
is inserted in the Destination box.

6. Wait while the disk space is being verified. 

You will see a screen that asks you to wait while the disk space is being 
verified. Then the summary information screen appears. This screen 
summarizes the selections you have made and the disk space 
requirements.

7. Wait while the products are installed.

While files are being copied, you can track the Installation progress in the 
progress bar. When the bar shows a 100 percent progress, you must wait 
while the uninstall program is created. The final installation status is then 
displayed, with the message that the tool has finished installing. 
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Invoking CosmosScope on Windows
If errors are displayed in the final installation status, see the install log for 
details. 

Click Finish to exit the installation program.

Invoking CosmosScope on Windows

To invoke CosmosScope on Windows platforms, 

1. Check that your SNPSLMD_LICENSE_FILE, LM_LICENSE_FILE, or 
another tool-specific license variable is set to a valid licensing server. If 
licenses are not available, CosmosScope will fail when invoked. For detailed 
instructions on setting the license variable, see Installing Synopsys Tools.

The port and host name variables correspond to the TCP port and license 
server host name specified in the SERVER line of the Synopsys license file. 

Each license file can contain licenses for many packages from multiple 
vendors. You can specify multiple license files by separating each entry with 
a colon (:) for UNIX or a semicolon (;) for Windows.

2. Start the tool by choosing Start > Programs > Synopsys > product version 
> CosmosScope. 

The CosmosScope window opens. 

3. To check the product version, choose Help > About CosmosScope, and in 
the window that opens, click Copyright/Legal.

4. To exit CosmosScope, choose File > Exit.

Setting Up the User Environment on UNIX 

To set up the user environment, you must specify the location of the executable 
files and set the license environment variable.

The directory containing the executable commands is located within the ai_bin 
directory in the install_home installation root.

Specifying the Executable File Location

To set up a new CosmosScope user, add the executable file to the path. 
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Installing CosmosScope
Verifying the CosmosScope Installation on UNIX
■ If you are using the C shell, add the following line to the .cshrc file:

set path=(install_home/ai_bin $path)

■ If you are using the Bourne, Korn, or Bash shell, add the following line to the 
.profile, .kshrc, or .bashrc file:

PATH=install_home/ai_bin: $PATH
export $PATH

Setting the SNPSLMD_LICENSE_FILE or
LM_LICENSE_FILE Environment Variables

You must install the SCL software and define the SNPSLMD_LICENSE_FILE, 
LM_LICENSE_FILE, or another tool-specific variable before you can verify the 
CosmosScope installation. 

For information about downloading and installing SCL and on setting the 
license variable, see Installing Synopsys Tools.

Verifying the CosmosScope Installation on UNIX 

To verify the installation of the CosmosScope tools,

1. Make sure you are in a directory where you have read/write privileges.

% cd $HOME

2. Invoke the tool by entering 

% cscope &

If the CosmosScope tools are correctly installed, this command invokes 
CosmosScope, displays the CosmosScope welcome screen, then opens the 
tool.
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Viewing and Printing CosmosScope Documentation in Portable Document Format
Viewing and Printing CosmosScope Documentation
in Portable Document Format

To view and print CosmosScope documentation in Portable Document Format 
(PDF), you must have Adobe Acrobat Reader installed on your machine. To 
determine which version of Adobe your operating system requires, see Table 5 
on page 14.

Adobe Reader Full-Text Search Issue on UNIX 

When you do a full-text search of CosmosScope documentation on UNIX 
operating systems, you might see the following error message: 

The file mentioned in the message, index.pdx, is a full-text search index that 
lets you search a collection of manuals shipped with your release. This 
message appears when your version of Adobe Reader cannot use the version 
of the full-text search index provided. 

You can use CosmosScope documentation without the full-text search feature. 
All other features, including searches within a single document, still work. The 
only task you will not be able to do is to search more than one document in the 
collection.
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Installing CosmosScope
Viewing and Printing CosmosScope Documentation in Portable Document Format
Table 5 shows which version of Adobe Reader you need to use with a particular 
release. It also indicates whether full-text search is available for a particular 
platform and release.

For detailed information, see SolvNet article 017761, “An Error Message 
Appears When Doing a Full-text Search of Synopsys Product Documentation.”

Table 5 Platform and Supported Version 

Platform Product documentation 
version

Full-text search 
available

Adobe Reader version 

HP-UX Y-2006.03,  Y-2006.06 
or later

X-2005.12 or earlier

No

Yes

Adobe Reader 5.0 or 
earlier

Adobe Reader 5.0 or 
earlier

IBM RS/6000 (AIX) Y-2006.03,  Y-2006.06 
or later

X-2005.12 or earlier

No

Yes

Adobe Reader 5.0 or 
earlier

Adobe Reader 5.0 or 
earlier

Linux Y-2006.03,  Y-2006.06 
or later

X-2005.12 or earlier

Yes

No

Adobe Reader 7.0

Any version

Sun SPARC  

(Solaris)1

1. On Solaris operating systems, the GNOME desktop manager must be installed to support Adobe 
Reader 7.0.

Y-2006.03,  Y-2006.06 
or later

X-2005.12 or earlier

Yes

Yes

Adobe Reader 7.0

Adobe Reader 5.0 or 
earlier

Windows Y-2006.03,  Y-2006.06 
or later

X-2005.12 or earlier

Yes

Yes

Adobe Reader 6.0 or 7.0

Any version
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Using Command Options 

You can install CosmosScope on UNIX platforms by using the setup script 
command and on Windows by invoking the setup.exe installation program. 
By default, the CosmosScope installer invokes the GUI installation program on 
all platforms. If you want to install the software in silent mode or in the 
background, use the -silent command-line option, which is supported on all 
platforms. If you do not use the -silent option at the command line, any 
option you enter is reflected in the GUI.

The following options are available from the command line. Unless otherwise 
indicated, they are available for both UNIX and Windows systems.

Usage:setup [options]

-silent

Suppresses all graphics output.

-installdir destination directory 

Installs files to a destination directory. The path name cannot include 
spaces.

-typical (default)

 Installs typical features.

-license port host1 [host2 host3] [license file] (Windows 
only)

Sets up licensing services on Windows platforms. If you specify a license 
file, the file must already exist and have an absolute path name. If you don’t 
specify a license file, the default license file path name is used. You can 
change the default after installation.

The SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE environment 
variable is set using the port and host information specified. If the 
SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE environment variable 
already exists, only unique port and host information will be added. 

Regardless of whether the -license option is used, the lmgrd and avantd 
daemons are always installed, so you can set up license services manually 
after installation.

To set up or modify a local Windows license server, use the Macrovision 
LMTOOLS utility, which you can access by choosing Start > Programs > 
Synopsys > CosmosScope version > License Tool.
Installing CosmosScope 15
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To set or modify the SNPSLMD_LICENSE_FILE or LM_LICENSE_FILE 
environment variable, open the Control Panel and choose System > 
Environment (Windows NT) or System > Advanced > Environment Variables 
(Windows 2000 or later). You cannot use LMTOOLS to modify environment 
variables.

-is:tempdir temporary directory

Specify an alternative location in which to store temporary files. On UNIX 
platforms, the default temporary directory might not contain enough free 
space to install the tool, causing the installer to terminate abnormally. 

Troubleshooting CosmosScope Startup on Windows 

The HOME directory (C:\Documents and Settings\username) must exist. If it 
doesn’t exist, when you launch CosmosScope on a Windows platform, you will 
see the following error message:

 “Error evaluating –c supplied command” 
can’t create directory “username” no such file or directory 
while executing
    “error $res” 
...

If the directory exists, but this message still appears, you must explicitly set the 
HOME variable. 

To set the variable, 

1. Choose Start > Settings > Control Panel > System > Advanced > 
Environment Variables. 

2. In the Environment Variable dialog box under “System variables,” click New.

3. In the “Variable name” box, enter HOME. In the “Variable value” box, enter the 
path. For example, 

C:\Documents and Settings\username

Replace username with your name.
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Uninstalling the Software

If license servers are running or the product was recently invoked, stop the 
license server and any aimsh processes. If these processes are not stopped 
before you uninstall the tool, the files might not be fully removed. If this occurs, 
manually delete any remaining files and delete the vpd.properties file located in 
the user’s home directory (on Windows, in C:\Windows).

When you are using the uninstall program from the command line, the -
silent option is also available. The -silent option suppresses all graphics 
output.

To uninstall the software on UNIX,
■ Execute the uninstall program, which is located in the  Install_home/

_CosmosScope directory, or delete the entire software directory. 

If you delete the directory, you must also delete the vpd.properties file 
located in your home directory.

To uninstall the software on Windows, 
■ From the Control Panel, select Add/remove programs.

or
■ Choose Start > Programs > Synopsys >CosmosScope version > Uninstall. 

The uninstall program will automatically start. 

or
■ Execute the uninstall program located in the 

Install_home\_CosmosScope directory. For example,

c:> install_home\_CosmosScope\uninstall

The uninstall program will start.

Customer Support

For information about accessing customer support, see Installing Synopsys 
Tools.
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